
General Notice

When using this document, keep the following in mind:

1. This document is confidential.  By accepting this document you acknowledge that you are bound 
by the terms set forth in the nondisclosure and confidentiality agreement signed separately and in 
the possession of SEGA.  If you have not signed such a nondisclosure agreement, please contact 
SEGA immediately and return this document to SEGA.

2. This document may include technical inaccuracies or typographical errors.  Changes are periodi-
cally made to the information herein; these changes will be incorporated in new versions of the 
document.  SEGA may make improvements and/or changes in the product(s) and/or the 
program(s) described in this document at any time.

3. No one is permitted to reproduce or duplicate, in any form, the whole or part of this document 
without SEGA’S written permission.  Request for copies of this document and for technical
information about SEGA products must be made to your authorized SEGA Technical Services 
representative.

4. No license is granted by implication or otherwise under any patents, copyrights, trademarks, or 
other intellectual property rights of SEGA Enterprises, Ltd., SEGA of America, Inc., or any third 
party.

5. Software, circuitry, and other examples described herein are meant merely to indicate the 
characteristics and performance of SEGA’s products.  SEGA assumes no responsibility for any 
intellectual property claims or other problems that may result from applications based on the 
examples described herein.

6. It is possible that this document may contain reference to, or information about, SEGA products 
(development hardware/software) or services that are not provided in countries other than Japan.  
Such references/information must not be construed to mean that SEGA intends to provide such 
SEGA products or services in countries other than Japan.  Any reference of a SEGA licensed prod-
uct/program in this document is not intended to state or imply that you can use only SEGA’s 
licensed products/programs.  Any functionally equivalent hardware/software can be used instead.

7. SEGA will not be held responsible for any damage to the user that may result from accidents or any 
other reasons during operation of the user’s equipment, or programs according to this document.
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■ Introduction

MapEditor and ScreenEditor are applications that read multiple images
stored in formats such as PICT and DGT2, divide pixels into character
units and place these character units in a desired area (map).  It is mainly
used to create scroll data.

The edited data can be saved in SEGA2D format.

The MapEditor supports "Character size=2 cell x 2 cell" mode.

The ScreenEditor supports "Character size=1 cell x 1 cell" mode.

■ Tool Palette

Basic operations of the tool palette are similar to that of ordinary graphics
applications.  Although most applications edit pixels, MapEditor and
ScreenEditor edit images in "character" units.



◆ Rectangle Select Tool

• Selecting

Drag:  Selects a rectangular area.

Shift + drag:  Adds a selected area.

Command (�) + drag:  Deletes a specified area from the rectangular
selection.

Shift + � + drag:  Selects the overlapping area between the specified
area and selection.

Click:  Cancels the selection.

• After Selecting (the selected area)

Drag:  Moves the selected area.

Option + drag:  Copies and moves the selected area.

Click:  Cancels the selection.

◆ Select Tool

• Selecting

Click:  Selects a character

Shift + click:  Adds a character to the selected area.

Command (�) + click:  Deletes a character from the selected area.

Shift + � + click:  Selects the overlapping area between the specified
character and selection.

• After Selecting (the selected area)

Drag:  Moves selected area.

Option + drag:  Copies and then moves the selected area.

Click:  Cancels the selected area.

◆ Eraser Tool



Drag:  Draws using erase data.

Double-click:  Erases data in the selected area.

◆ Pencil Tool

Drag:  Draws using specified data.

Option + click:  Specifies the data at the clicked position.

◆ Magnifying Glass Tool

Click:  Doubles the magnification of the display.

Option + click:  Halves the magnification of the display.

◆ Rectangle Tool

Drag:  Draws a rectangular area and fills with specified data.

Option + click:  Selects the clicked data.

◆ Eyedropper Tool

Click:  Selects the clicked data.

◆ Drag-Drop Tool

Transfers the selected image data by dragging and dropping to other
windows or other tools that support the drag-drop function.

This function is valid in selected areas on an Image or CG window.



Note that the palette information may be damaged when transferring to
other tools, etc., since the data is transferred as PICT data.

■ File Menu

Manages input and output of files.  Quit the application in this menu.

● New...

Displays a dialog box and opens a new file.  Note that parameters other
than the map size cannot be changed during editing.

◆ Map Size:

Enter the map size in page (1 page=512 x 512 dots ) units.

◆ Color Mode:

Specify the color mode for the new file.

◆ Pattern Name Size:

Specify the pattern name size for the new file.

● Open...

Reads the existing SEGA2D file.

● Close



Temporarily closes the active window.

● Save

Saves the edited file in SEGA2D format under the same name.

● Save As...

Saves the edited file in SEGA2D format under the specified name.

● Import...

Reads image files in the specified format and opens an Image window.
Select a palette when a character is edited using the palette mode.

◆ Replace Color

 Select this box to use the palette data of the imported image.  When
there is no palette data, (full-color images and the like), an optimal
palette is generated automatically.  The current palette data is used if
this box is not checked off.

◆ Palette Mode

Selects palette mode.  The selection is limited by the color mode set
for the editing file.



• 16

This can be selected if a file is in 16-color mode.  Opens an Image
window in 16 colors.

• 16 x 16

This can be selected if a file is in 16-color mode.  Opens an Image
window with the assumption that each character of the image file
has 16 or fewer colors with multiple palettes in mind.

• 256

Forcibly selected when a file is in 256-color.  Opens an Image
window in 256 colors.

● Export...

Saves an image in the Map window as an image file in the specified
format.  Saved in single page units.

● Quit

Ends the application.

■ Edit Menu

Editing may be done in all windows.  The basic operations are the same as
standard Macintosh applications.

"Character editing" and "map editing" functions may vary.

● Undo

Cancels the previous edit.  Select again to redo.

● Cut

◆ During Character Editing

Saves the character image in the selected area and the pattern name
configuration to the clipboard.  The selected character is deleted using
the #0 code.

◆ During Map Editing

Saves the pattern name configuration in the selected area to the
clipboard.  The pattern name in the selection is filled with #0
characters.

● Copy

◆ During Character Editing



Saves the character image in the selected area and the pattern name
configuration to the clipboard.  The pattern name in the selection is
left as is.

◆ During Map Editing

Saves the pattern name configuration in the selected area to the
clipboard.  The pattern name in the selection is left as is.

● Paste

◆ During Character Editing

Pastes the character image saved on the clipboard to another character
window.

◆ During Map Editing

Pastes the pattern name configuration saved on the clipboard to the
Map window.

● Delete

◆ During Character Editing

Clears characters in the selected range using the #0 code.

◆ During Map Editing

Fills the pattern name in the selected range with #0 characters.

● Select All

Selects everything in the window.

*Character images that are saved to the clipboard during character
editing can be copied and pasted between various applications as PICT
data.

*The pattern name configuration saved on the clipboard during
character editing can be pasted to a Map window.

■ Option Menu

● Grid

Displays grids in character units on all Edit windows.

Also displays grids in page units on Map windows.

● Zoom

Specifies the display magnification (x1, x2, x4) for all Edit windows.  The
Map window can also be reduced (1/2, 1/4).



● Display

Specifies the data type for composite display on the Edit windows.

◆ Attribute

Displays the attribute number.

◆ Special Priority

Characters with their priority flags up are displayed in a blue
checkered pattern.

◆ Special Color Calculation

Characters with their color operation flags up are displayed in a red
checkered pattern.  This calculation is displayed only in the Map
window.

● Get Info

Displays an information window during character editing and map
editing.

◆ Character window information

◆ Map window information

Decimal and hexadecimal format display can be selected in both
information windows.



◆ Dec:  Displays the information in decimal

◆ Hex:  Displays the information in hexadecimal.

■ Image Menu

This menu can be used when the Character window is active, to edit
character data directly.

● Flip

Flips the character image in a specified area.

◆ H Flip

Flips an image horizontally.

◆ V Flip

Flips an image vertically.

● Rotate

Rotates the character image in a specified area.

◆ +90°

Rotates an image 90° counter clockwise.

◆ -90°

Rotates an image 90° clockwise.

● Attribute...

Sets attribute data to the characters in the specified area.

This function cannot be used in ScreenEditor.

● CG Display Palette...

Sets palette used in the character window display.  The information set
here does not affect the output files.  This function attempts to increase
editing efficiency based on intuitive visual senses.

● Sort...

Merges and sorts the character data in the selected area according to the
specified criteria.  The result of sorting is reflected in the pattern name
data in the Map window.

The purpose of this function is to pack character data in a given data
space.



◆ H Flip

Merges horizontally flipped images.  A horizontal flip flag is set on
data that is H flipped in the Map window.

◆ V Flip

Merges vertically flipped images.  A vertical flip flag is set on data that
is V flipped in the Map window.

◆ Attribute

Merges attribute data.

This function cannot be used in ScreenEditor.

● Offset...

Moves all character data by the specified offset.  The result is reflected in
the Map window data.

This function is mostly used when a provision or restriction is made
later and an edited character or map data must be moved.

● Check Use

Erases characters that do not exist in the current map with a #0 code.

This function is used mostly to eliminate unnecessary data from
complex map data or character data that is difficult to distinguish.  Use
with the Sort function.

■ Flag Menu

This menu is activated when the Map window is active.

Sets various SEGA SATURN VDP2 flags.

● H Flip

Sets a horizontal flip flag to a pattern name in the selected area.

● V Flip



Sets a vertical flip flag to a pattern name in the selected area.

● Special Priority

Sets a special priority flag to a pattern name in the selected area.

● Special Color Calculation

Sets a special color calculation flag to a pattern name in the selected area.

● Palette

Changes the palette for a pattern name in the selected area.

● Map Size

Changes the size of the area that is edited in the Map window.  Enter the
map size in single page units.  Please note that if the editing area is
changed to a smaller map size than the current one, the area will be cut
off.

■ Window Menu

● Image Window

Displays or activates the Image window.

● CG Window

Displays or activates Character window.

● Map Window

Displays or activates Map window.

● Edit Palette...

Displays Palette Edit Window and edits color/palette data.



◆ R

Changes the intensity of red in the selected area.

◆ G

Changes the intensity of green in the selected area.

◆ B

Changes the intensity of blue in the selected area.

◆ H

Changes the hue of the color in the selected area.

◆ S

Changes the saturation of a color in the selected area.

◆ L

Changes the brightness of the color in the selected area.

◆ V

Changes the value of the color in the selected area.

◆ Copy



Rewrites the selected area of the color table to a position on the selected
palette.

◆ Swap

Swaps the selected area of the color table with color table on the selected
palette.

◆ Entry

Shows the results of editing in the CG and Map windows.

◆ Revert

Undoes the edits.  Reverts to the status at the previous "Entry".
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■ Before Beginning the Editing Process

There are some settings in the MapEditor/ScreenEditor that cannot be
modified once the editing process is started.  Check all the settings that are
entered at startup before creating a new map.

*Please refer to the VDP2 Manual for information on color modes and
pattern name tables.

■ Registering Characters

Open the Image window by selecting "Import" from the File menu and
read the image file to register as a character.

Next, specify an area on the Image window using the rectangle select tool
or the select tool.  Cut and paste the selection to the CG window to register
it as a character.



Image data copied from other applications may also be pasted directly onto
the CG window.

■ Editing Characters

Create new character data by pasting data from the Image window.
Data may also be copied and pasted from other applications.

Use the rectangle select tool and select tool to specify an area, copy and
paste, modify the position or use the Image menu to perform various
edits.

As an optional function, multiple selections can be copied to the Map
window while maintaining the same positions as the original.

● Setting Attributes
Attributes are supplemental information given to each character.
Desired data may be set on the map for the program to process.
Select "Attribute" from the Image menu to open a dialog box.
Enter a value as the attribute data for the specified character.

Go to the Option menu and check off "Attributes" under "Display" to
check the attribute data that is set.



● Display Palette
The character in the CG window is displayed using a temporary palette
because the CG data itself does not have palette information.
If the temporary palette disrupts the registering of characters for multiple
palette use, change the display palette by selecting "CG Display Palette"
from the Image menu.



Modification of the palette affects all character areas in the CG window.
Also, the current palette information is attached to all data registered in
the map.

● Sort
Finds overlapping characters by searching for several conditions and
combines as a single character.
First, specify the area in the CG window to be sorted.  Then select "Sort"
from the Image menu to display a dialog box.



Set the necessary conditions and sort.

If a character is moved during sort, the positional change is reflected in
the map data.

● Offset
Moves back the registered positions of all the registered characters by a
specified number of characters.
Select "Offset" from the Image menu to display a dialog box.

When a character is moved by specifying an offset, the move is reflected
in the map data.

● Check Use



Replaces registered characters that are not used as map data with the 0th
character.
If unused character areas need to be shifted forward after this process,
use "Sort".

■ Editing Maps

Character data is positioned on a template.  Select this data and position
it on the map using the pencil or rectangle tool.

Drag multiple characters to select more than one character from the
template at a time.
Also, use the rectangle select tool or the select tool to select an area on
the map window, to copy and paste a selection, modify the position or
use combination with the Flag menu to set various flags.
To reflect imported image data in the map, register the image data as a
character in the CG window, copy the data and paste into the map
window.  Sorting, etc., after this process eliminates the trouble of
restructuring fragmented characters.

● H flip, V flip
Modifies the position of the selected map data, sets and cancels the
horizontal/vertical flip flag.  The map data is displayed according to the
flag setting.



● Special Priority, Special Color Calculations
Sets and cancels the special priority and special color calculations for the
selected range.  These display modes are under "Display" in the Option
menu.

*Blue:  special priority setting area
*Red:  special color calculation setting area



● Palette
A palette is assigned to a map data in character units.
Specify the range in the map window and select "Palette" from the Flag
menu to display the dialog box.
Enter the starting address value of the palette or click the area on the
palette list to select the palette to be modified.



*The address unit ($10/$100) that can be selected is dependent upon the
color mode at initialization.

■ Editing Palettes

Palette data is edited in the Palette Edit window.  Character data can be
edited when in the palette mode (16 colors/256 colors).

Select the area using the rectangle select tool, select tool to modify the
palette data.



MapEditor 1.81E/ ScreenEditor 1.07E
Release Notes

■ Information on version upgrade

◆ The sorting problem has been corrected (MapEditor).

◆ The problem related to the import function has been corrected
(Map/ScreenEditor).

■ Restrictions
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